Error: Cask ‘vagrant’ definition is invalid: Bad header line: parse failed

Problem:
You need to update vagrant to get some work done and trying to use brew to install vagrant is failing with an error message of "Error: Cask 'vagrant' definition is invalid: Bad header line: parse failed".

Solution:

You probably haven't updated brew in a really long time. Here's how to get that working again.

brew update; brew cleanup; brew cask cleanup
brew uninstall --force brew-cask; brew update

Thanks to adidalal of the caskroom project for this solution.

 

 

derak

 

Leave a Reply

Your email address will not be published. Required fields are marked *